prev
next
ru.linux
FromVictor Sudakov2:5005/49.0Date Write2017-10-29 21:30:09
ToEugene Muzychenko0:0/0.0Date Arrived2017-10-29 17:51:01
SubjПоиск проблем в OpenWRT/LEDE
Attr
Dear Eugene,

29 Oct 17 17:58, you wrote to All:
EM> Hастраиваю новый маршрутизатор, прошив туда LEDE 17.01.4. Стандартная
EM> WiFi-сеть, привязанная к LAN, работает нормально, кабельные
EM> подключения (WAN/LAN) тоже. Добавил гостевую сеть, привязанную к
EM> отдельному интерфейсу с собственным диапазоном DHCP - устройства не
EM> могут к ней подключиться, циклически запрашивая IP-адрес, но не
EM> получая его.

EM> Смотрю лог (уровень Debug) - там какая-то невразумительная херня:

Не вижу в этом логе ни слова про DHCP, вижу только сообщения hostapd, поэтому
рискну предположить, что DHCP сервер просто не работает (не запущен, либо не
настроен диапазон, либо не слушает на интерфейсе), поэтому WiFi устройства
просто тупо переподключаются в надежде, что когда-нибудь им DHCP сервер таки
ответит.

EM> По таким "отладочным" сообщениям как-то можно понять, что происходит в
EM> DHCP-сервере?

Никак.

EM> Hу реально же убогий лог, без вариантов.

EM> В этих системах вообще есть сколько-нибудь целенаправленные способы
EM> поиска глюков, или основным способом решения проблемы является метод
EM> последовательного тыка? :)

Если туда можно зайти по ssh или telnet, посмотреть список процессов, конфиги
dhcpd и т.п. - то ответ положительный, способы есть.

Victor Sudakov, VAS4-RIPE, VAS47-RIPN
--- GoldED+/BSD 1.1.5-b20160322-b20160322
* Origin: Ulthar (2:5005/49)