prev
next
ru.linux.redhat
FromAlexey Vissarionov2:5020/545.0Date Write2012-11-23 20:40:00
ToRinat H. Sadretdinow0:0/0.0Date Arrived2012-11-23 21:00:02
SubjКак можно заюзать более старый libmysqlclient?
Attr
Доброго времени суток, Rinat!
23 Nov 2012 18:50:46, ты -> мне:

RHS>>>>> Я хочу запустить эту программу под Fedora 17, а в Федоре AFAIR
RHS>>>>> libmysqlclient.so.18 и естественно эта программа не запускается.
AV>>>> Показывай `rpm -qa | grep mysql`
RHS>>> mysql-5.1.61-1.el6_2.1.i686.rpm
RHS>>> mysql-libs-5.1.61-1.el6_2.1.i686.rpm
RHS>>> mysql-server-5.1.61-1.el6_2.1.i686.rpm
RHS>>> Это я из kikstart'а оттуда взял, к нему у меня доступ есть.
AV>> Hу вот, собственно, и решение: сноси 5.5 и ставь 5.1
RS> До первого `yum update`?

Да с хрена бы, если у тебя от него другой пакет (с той софтиной) зависит?
А если нет, или хочешь перестраховаться, сделай так:

==== хрум mysql-lockversion.spec ====
Summary: MySQL version lockup
Name: mysql-lockversion
Version: 0.1
Release: 1
License: GPL
Group: System/Utilities
URL: http://hren.tebe.ru
AutoReq: false
Requires: mysql = 5.1.66
BuildArchitectures: noarch
BuildRoot: %{_tmppath}/%{name}-%{version}-root

%description
This package simply depends on exact MySQL version

%files
%defattr(-,root,root)
==== тьфу mysql-lockversion.spec ====


--
Alexey V. Vissarionov aka Gremlin from Kremlin
gremlin ПРИ gremlin ТЧК ru; +vii-cmiii-ccxxix-lxxix-xlii

... МБР с ядерной БЧ - божья кара, созданная атеистами
--- /bin/vi
* Origin: http://openwall.com/Owl/ru (2:5020/545)